unable to create pool


Hi team,
So I have a basic set of daos client and server running. when I run dmg storage query commands on the client-side, I get responses, it means I am able to interact with the server. But when i run this pool create command: -
dmg -i pool create -s 1G -n 10G -g root -u root -S daos_server. the response is:
Creating DAOS pool with manual per-server storage allocation: 1.0 GB SCM, 10 GB NVMe (10.00% ratio)
It stays like this for a really long time then I get an error.
ERROR: dmg: context deadline exceeded

I am configuring the server with the daos_server_local.xml config file. This means my SCM is set to ram and my NVMe is set to file to emulate the scm and NVMe. I thought we can still create pools on the emulated storage. Am I doing something wrong? Can I not create pools on emulated SCM? Because without creating a pool I can not really do anything else. 
I am attaching a screenshot of the same error for reference. Please let me know what could I be possibly doing wrong. Or if creating pools on emulated SCM storage is not supported.