Topics

spark/unsupported JNI Version 0xFFFFFF15

timehuang88@...
 

Hi guys,
When I try to build and support spark and hadoop, I got a problem below.
What should I do to solve this problem.


Zhang, Jiafu
 

Hi,

 

1003 is invalid variable error. You can see the error code mapping here. As talked, it should be related to your DAOS environment variables.

 

Thanks.

 

From: daos@daos.groups.io <daos@daos.groups.io> On Behalf Of timehuang88@...
Sent: Saturday, June 6, 2020 5:58 PM
To: daos@daos.groups.io
Subject: [daos] spark/unsupported JNI Version 0xFFFFFF15

 

Hi guys,
When I try to build and support spark and hadoop, I got a problem below.
What should I do to solve this problem.


timehuang88@...
 
Edited

Hi, Jiafu
it do a environment variable related problem. I forgot to set  OFI_INTERFACE and CRT_PHY_ADDR_STR env variables, since I opened a new terminal.
thx for ur suggestion!
2