Topics

GCC Version


Colin Ngam
 

Greetings,

 

What GCC version is required for building daos v1.0.0?

 

Just want to verify as I am getting:

..

In file included from crc/crc32c.h:23:0,

                 from crc/crc32c.c:33:

crc/../arch/arch.h:4:23: fatal error: stdatomic.h: No such file or directory

#include <stdatomic.h>

                       ^

compilation terminated.

 

The log recommends GCC 4.9 and up. We are using 4.8.

 

Thanks.

 

Colin

 


Colin Ngam <cngam@...>
 

Greetings,

 

What GCC version is required for building daos v1.0.0?

 

Just want to verify as I am getting:

..

In file included from crc/crc32c.h:23:0,

                 from crc/crc32c.c:33:

crc/../arch/arch.h:4:23: fatal error: stdatomic.h: No such file or directory

#include <stdatomic.h>

                       ^

compilation terminated.

 

The log recommends GCC 4.9 and up. We are using 4.8.

 

Thanks.

 

Colin


Olivier, Jeffrey V
 

Hi Colin,

 

What platform are you building on and do you know what prerequisite component is being built when you get that message?   Sounds like a bug in that component’s configure script.    In theory, DAOS should work with and without stdatomic.h

 

-Jeff

 

From: <daos@daos.groups.io> on behalf of Colin Ngam <cngam@...>
Reply-To: "daos@daos.groups.io" <daos@daos.groups.io>
Date: Thursday, June 25, 2020 at 4:01 PM
To: "daos@daos.groups.io" <daos@daos.groups.io>
Subject: [daos] GCC Version

 

Greetings,

 

What GCC version is required for building daos v1.0.0?

 

Just want to verify as I am getting:

..

In file included from crc/crc32c.h:23:0,

                 from crc/crc32c.c:33:

crc/../arch/arch.h:4:23: fatal error: stdatomic.h: No such file or directory

#include <stdatomic.h>

                       ^

compilation terminated.

 

The log recommends GCC 4.9 and up. We are using 4.8.

 

Thanks.

 

Colin


Venkatesan, Vishwanath
 

Hi Colin,

 

I think this is coming from FIO with their latest ‘atomics’ patch in the latest master.
You can change the fio version to their latest release (3.20) and recompile to fix this problem.

So from daos source tree

cd _build.external/fio/ && git checkout fio-3.20

and recompile with scons.

 

HTH

 

Cheers,

Vish

--------------------------------------------------

Vishwanath Venkatesan

Software Development Engineer

Extreme-scale Storage Architecture and Development (ESAD)

Intel Corporation

 

From: <daos@daos.groups.io> on behalf of "Olivier, Jeffrey V" <jeffrey.v.olivier@...>
Reply-To: "daos@daos.groups.io" <daos@daos.groups.io>
Date: Monday, June 29, 2020 at 11:32AM
To: "daos@daos.groups.io" <daos@daos.groups.io>
Subject: Re: [daos] GCC Version

 

Hi Colin,

 

What platform are you building on and do you know what prerequisite component is being built when you get that message?   Sounds like a bug in that component’s configure script.    In theory, DAOS should work with and without stdatomic.h

 

-Jeff

 

From: <daos@daos.groups.io> on behalf of Colin Ngam <cngam@...>
Reply-To: "daos@daos.groups.io" <daos@daos.groups.io>
Date: Thursday, June 25, 2020 at 4:01 PM
To: "daos@daos.groups.io" <daos@daos.groups.io>
Subject: [daos] GCC Version

 

Greetings,

 

What GCC version is required for building daos v1.0.0?

 

Just want to verify as I am getting:

..

In file included from crc/crc32c.h:23:0,

                 from crc/crc32c.c:33:

crc/../arch/arch.h:4:23: fatal error: stdatomic.h: No such file or directory

#include <stdatomic.h>

                       ^

compilation terminated.

 

The log recommends GCC 4.9 and up. We are using 4.8.

 

Thanks.

 

Colin