dfuse can't access /var/run/daos_agent/agent.sock


Ruben Felgenhauer <4felgenh@...>
 

I am using the config file from daos/utils/config/examples/daos_server_local.yml with the only difference that I'm not using the bdev lines and with an scm_size of 50 GB.

 I'd like to test daos' fuse fileystem, but sadly it crashes directly on startup. I tried the following two lines:

$ OFI_INTERFACE=eth0 dfuse -S --mountpoint="$DFS_MNT" --svc="$DAOS_SVCL" --pool="$DAOS_POOL" --foreground
$ OFI_INTERFACE=eth0 dfuse_hl "$DFS_MNT" -s -f -d -p "$DAOS_POOL" -l "$DAOS_SVCL"
Pool Connect...
DFS Pool = 5092de74-348c-4c99-8c19-875c14523f86
DFS SVCL = 0
Failed to connect to pool (-1026)

Note that the first one crashes without any error message. In both cases, the /tmp/daos.log reads:

05/22-18:41:26.80 abu2 DAOS[64779/64779] daos ERR  src/common/drpc.c:173 unixcomm_connect() Failed to connect to /var/run/daos_agent/agent.sock,              errno=2(No such file or directory)
05/22-18:41:26.80 abu2 DAOS[64779/64779] mgmt ERR  src/mgmt/cli_mgmt.c:296 get_attach_info() failed to connect to /var/run/daos_agent/agent.sock

Does DFS not work with daos_server_local.yml? Setting the socket_dir variable in the config file doesn't seem to help either.

Kind regards
Ruben


Farrell, Patrick Arthur
 

Do you have the daos_agent running?  You didn't mention that aspect - it must be running on any clients.  There are more details in the manual.

Regards,
-Patrick


From: daos@daos.groups.io <daos@daos.groups.io> on behalf of Ruben Felgenhauer <4felgenh@...>
Sent: Friday, May 22, 2020 11:47 AM
To: daos@daos.groups.io <daos@daos.groups.io>
Subject: [daos] dfuse can't access /var/run/daos_agent/agent.sock
 
I am using the config file from daos/utils/config/examples/daos_server_local.yml with the only difference that I'm not using the bdev lines and with an scm_size of 50 GB.

 I'd like to test daos' fuse fileystem, but sadly it crashes directly on startup. I tried the following two lines:

$ OFI_INTERFACE=eth0 dfuse -S --mountpoint="$DFS_MNT" --svc="$DAOS_SVCL" --pool="$DAOS_POOL" --foreground
$ OFI_INTERFACE=eth0 dfuse_hl "$DFS_MNT" -s -f -d -p "$DAOS_POOL" -l "$DAOS_SVCL"
Pool Connect...
DFS Pool = 5092de74-348c-4c99-8c19-875c14523f86
DFS SVCL = 0
Failed to connect to pool (-1026)

Note that the first one crashes without any error message. In both cases, the /tmp/daos.log reads:

05/22-18:41:26.80 abu2 DAOS[64779/64779] daos ERR  src/common/drpc.c:173 unixcomm_connect() Failed to connect to /var/run/daos_agent/agent.sock,              errno=2(No such file or directory)
05/22-18:41:26.80 abu2 DAOS[64779/64779] mgmt ERR  src/mgmt/cli_mgmt.c:296 get_attach_info() failed to connect to /var/run/daos_agent/agent.sock

Does DFS not work with daos_server_local.yml? Setting the socket_dir variable in the config file doesn't seem to help either.

Kind regards
Ruben


Ruben Felgenhauer <4felgenh@...>
 

Thanks for the quick reply. I did indeed forget to do that. It works fine now.

Kind regards
Ruben