DAOS command no longer giving output on failure


Farrell, Patrick Arthur <patrick.farrell@...>
 

Good morning,

I'm running commit:
commit 53b0c5ff3d45c8addfee11cbfd6dd49e6f88dc3e

And the daos container create command is no longer giving any output on failure:
[daos@hl-d102 ~]$ daos container create --pool=d885cc1f-9363-4342-a859-ec32b3230c08 --svc=1 16G
[daos@hl-d102 ~]$ daos container create --pool=d885cc1f-9363-4342-a859-ec32b3230c08 --svc=1
[daos@hl-d102 ~]$ daos container create --pool=d885cc1f-9363-4342-a859-ec32b3230c08
[daos@hl-d102 ~]$ daos container create --pool=d885cc1f-9363-4342-a859-ec32b3230c0

All of those failed.  I am not completely sure why they failed, and I'm capable of using debug to determine why (it's probably some sort of config issue), and obviously the first command is wrong.

The key point is:
None of them gave *any* output.  This makes troubleshooting a little tricky.

I'm not sure at what commit this last worked, but it definitely did a few weeks ago.

Thanks,
Patrick


Faccini, Bruno
 

Hello Patrick,

Well, this is really strange indeed. BTW, I am unable to reproduce when running with current master which is only 45 commits ahead of yours and none seem to be related…

If problem is still there or will reoccur, and you don’t want to debug it, could try to at least re-run one of these failing commands under strace tool ?

Thanks,

Bruno.

 

From: <daos@daos.groups.io> on behalf of "Farrell, Patrick Arthur" <patrick.farrell@...>
Reply to: "daos@daos.groups.io" <daos@daos.groups.io>
Date: Friday 8 May 2020 at 16:07
To: "daos@daos.groups.io" <daos@daos.groups.io>
Subject: [daos] DAOS command no longer giving output on failure

 

Good morning,

 

I'm running commit:

commit 53b0c5ff3d45c8addfee11cbfd6dd49e6f88dc3e

And the daos container create command is no longer giving any output on failure:

[daos@hl-d102 ~]$ daos container create --pool=d885cc1f-9363-4342-a859-ec32b3230c08 --svc=1 16G

[daos@hl-d102 ~]$ daos container create --pool=d885cc1f-9363-4342-a859-ec32b3230c08 --svc=1

[daos@hl-d102 ~]$ daos container create --pool=d885cc1f-9363-4342-a859-ec32b3230c08

[daos@hl-d102 ~]$ daos container create --pool=d885cc1f-9363-4342-a859-ec32b3230c0

 

All of those failed.  I am not completely sure why they failed, and I'm capable of using debug to determine why (it's probably some sort of config issue), and obviously the first command is wrong.

 

The key point is:
None of them gave *any* output.  This makes troubleshooting a little tricky.

 

I'm not sure at what commit this last worked, but it definitely did a few weeks ago.

 

Thanks,

Patrick

---------------------------------------------------------------------
Intel Corporation SAS (French simplified joint stock company)
Registered headquarters: "Les Montalets"- 2, rue de Paris,
92196 Meudon Cedex, France
Registration Number:  302 456 199 R.C.S. NANTERRE
Capital: 4,572,000 Euros

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.