update ipmctl


Nabarro, Tom
 

We have recently learned of a serious issue affecting systems with Apache Pass DCPM modules. The ipmctl utility (versions 02.00.00.3809 through 02.00.00.3816) was released with a bug that can cause the modules to be put into a state that requires a physical procedure to recover the modules. In order to avoid this issue, please ensure that you are running version v02.00.00.3820 or later (when running DAOS to prepare persistent memory modules).

More details…

When running DAOS and executing dmg storage prepare command to set persistent memory modules into AppDirect mode for use with DAOS, ipmctl which is forked at runtime, attempts to set a PMem configuration goal and fails if 02.00.00.3809-3816 version of ipmctl is installed. The failure is due to a corruption of the PCD on the DIMMs and results in system POST memory checks failing with fatal error.

ipmctl was fixed in this commit released in version v02.00.00.3820

That situation then requires recovery of persistent memory modules.

Prevention…

After installing DAOS and before running “dmg|daos_server storage prepare", please upgrade ipmctl to the most recent distro provided version with your preferred package manager e.g. sudo yum update ipmctl .

 

Work is in progress to add the necessary version checks to DAOS.

 

Regards,

Tom Nabarro – DCG/ESAD

M: +44 (0)7786 260986

Skype: tom.nabarro

 

---------------------------------------------------------------------
Intel Corporation (UK) Limited
Registered No. 1134945 (England)
Registered Office: Pipers Way, Swindon SN3 1RJ
VAT No: 860 2173 47

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.

Join daos@daos.groups.io to automatically receive all group messages.